Хостинг серверов Minecraft playvds.com
  1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.
  2. Вы находитесь в русском сообществе Bukkit. Мы - администраторы серверов Minecraft, разрабатываем собственные плагины и переводим на русский язык плагины наших собратьев из других стран.
    Скрыть объявление
  3. Данный раздел создан исключительно для релизов! Вопросы по лаунчеру или обвязке задавайте ТОЛЬКО в соответсвующей теме автора. Любые другие темы будут удалены, а авторы понесут наказание.

Веб L-Shop [Open Source]

Тема в разделе "Веб-обвязки и лаунчеры", создана пользователем D3lph1, 9 мар 2017.

  1. Автор темы
    D3lph1

    D3lph1 Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    D3lph1
    Если кто-то даст данные для доступа к аккаунту unitpay для отладки и тестирования, я буду только за.
     
    Последнее редактирование: 30 июн 2018
  2. Mr Hosting
  3. NewLordOfTime

    NewLordOfTime Новичок Пользователь

    Баллы:
    21
    А что планируется в новой версии? Если основную часть времени займет получение аттестата wm, то, может выпустить версию без unitpay пораньше, а с unitpay попозже?
    Или, как вариант, можно ли установить нынешнюю версию на сайт, настроить, а на новую обновиться? (Имеется ввиду обновление без потери "настроек")
     
  4. Автор темы
    D3lph1

    D3lph1 Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    D3lph1
    Unitpay тут ни при чем. Ещё не всё готово.
     
  5. NewLordOfTime

    NewLordOfTime Новичок Пользователь

    Баллы:
    21
    Ладно, не буду торопить, но...
    Можно ли будет, всё таки обновить, не потеряв, например список товаров(и прочее)?
     
  6. Автор темы
    D3lph1

    D3lph1 Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    D3lph1
    Да, инструмент для преобразования и миграции базы данных уже написан.
     
  7. NewLordOfTime

    NewLordOfTime Новичок Пользователь

    Баллы:
    21
    Будет ли работать магазин на php7.0 (php7.0.30), просто с установкой php7.1 как-то не задается
     
  8. Автор темы
    D3lph1

    D3lph1 Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    D3lph1
    Нет.
    Не пойму, в чем сложность? Какие кардинальные отличия от установки 7.0? Добавление репозитория?
     
  9. NewLordOfTime

    NewLordOfTime Новичок Пользователь

    Баллы:
    21
    Да дело в том, что добавляю я репозиторий (ondrej вроде), делаю update, в итоге php7.0 в нём есть, а php7.1 - нет. Юзаю debian 8.
     
  10. Aganus

    Aganus Активный участник Пользователь

    Баллы:
    68
    Имя в Minecraft:
    TheXaver
    Странно, удали старые репозитории и добавь новый
    • sudo add-apt-repository ppa:eek:ndrej/php
    • sudo apt-get update
    попутно удали все php
    apt-get purge php*
     
  11. NewLordOfTime

    NewLordOfTime Новичок Пользователь

    Баллы:
    21
    во-во, я, может не весь php удалил, сча поробую...
     
  12. NewLordOfTime

    NewLordOfTime Новичок Пользователь

    Баллы:
    21
    заметил, что после выполнения update не все пакеты грузятся:
    Код:
    Err http://ppa.launchpad.net jessie/all amd64 Packages
      404  Not Found
    Ign http://ppa.launchpad.net jessie/all Translation-en_US
    Ign http://ppa.launchpad.net jessie/all Translation-en
    Err http://ppa.launchpad.net jessie/main amd64 Packages
      404  Not Found
    Ign http://ppa.launchpad.net jessie/main Translation-en_US
    Ign http://ppa.launchpad.net jessie/main Translation-en
    Err http://ppa.launchpad.net jessie/main amd64 Packages
      404  Not Found
    Ign http://ppa.launchpad.net jessie/main Translation-en_US
    Ign http://ppa.launchpad.net jessie/main Translation-en
    Fetched 15.5 kB in 7s (2,065 B/s)
    W: Failed to fetch http://ppa.launchpad.net/ondrej/php/dists/jessie/all/binary-amd64/Packages  404  Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/ondrej/php/ubuntu/dists/jessie/main/binary-amd64/Packages  404  Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/ondrej/php-qa/ubuntu/dists/jessie/main/binary-amd64/Packages  404  Not Found
     
  13. Aganus

    Aganus Активный участник Пользователь

    Баллы:
    68
    Имя в Minecraft:
    TheXaver
    удали пакеты в /etc/apt/sources.list.d
    apt-get update
    sudo add-apt-repository ppa:eek:ndrej/php
    sudo apt-get update
     
  14. NewLordOfTime

    NewLordOfTime Новичок Пользователь

    Баллы:
    21
    у меня есть только:
    sources.list
    sources.list.save
    sources.list~ (пустой)
    при удалении из sources.list и sources.list.save пакетов загружается меньше, но в конце всё те же ошибки
     
  15. NewLordOfTime

    NewLordOfTime Новичок Пользователь

    Баллы:
    21
    php 7.1 поставить так и не смог, зато php 7.2 поставил :confused:
     
    Последнее редактирование: 2 июл 2018
  16. DJMixa

    DJMixa Активный участник Пользователь

    Баллы:
    66
    Имя в Minecraft:
    DJMixa
    Если бы установку скрипта показали в видео на DLE, для тупых, вот тогда было б топ
     
  17. NewLordOfTime

    NewLordOfTime Новичок Пользователь

    Баллы:
    21
    перехожу в /public/ бросает в /public/signin и пишет ошибку
    p.s composer install делал
     
  18. NewLordOfTime

    NewLordOfTime Новичок Пользователь

    Баллы:
    21
    при переустановке композера (удалил папку vendor и файл composer.lock) в конце пишет:
    Код:
    > Illuminate\Foundation\ComposerScripts::postAutoloadDump
    > @php artisan package:discover
    
    In AppServiceProvider.php line 83:
    
      Cannot instantiate interface D3lph1\MinecraftRconManager\Connector
    
    
    Script @php artisan package:discover handling the post-autoload-dump event returned with error code 1
     
  19. Автор темы
    D3lph1

    D3lph1 Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    D3lph1
    Да, это я обновил библиотеку. Поставьте оной версию 1.2 в composer.json.

    Либо же, восстановите composer.lock. Его удалять вообще не нужно было.
     
    Последнее редактирование: 13 июл 2018
  20. NewLordOfTime

    NewLordOfTime Новичок Пользователь

    Баллы:
    21
    и все же переусановка композера не помогла...
    при переходе в /public/ пишет:
     
  21. Автор темы
    D3lph1

    D3lph1 Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    D3lph1
    Во-первых, командой composer install вы устанавливаете не composer, а зависимости приложения.
    Во-вторых, дело не в зависимостях. Ошибка в неверной конфигурации веб-сервера, я подозреваю.
     

Поделиться этой страницей