Хостинг серверов Minecraft playvds.com
  1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.
  2. Вы находитесь в русском сообществе Bukkit. Мы - администраторы серверов Minecraft, разрабатываем собственные плагины и переводим на русский язык плагины наших собратьев из других стран.
    Скрыть объявление

Обсудим Нубятник №5 - помощь по самым простым вопросам.

Тема в разделе "Помощь", создана пользователем slenky, 19 янв 2016.

  1. VendettaMC

    VendettaMC Активный участник Пользователь

    Баллы:
    78
    Есть достаточно годная сборка, которую я планирую хостить у себя.
    И я хотел бы спросить, возможна ли поддержка версий 1.11.*, 1.12.*, если ядро Spigot 1.8.8.

    через ViaVersion;ProtocolSupport
     
  2. Mr Hosting
  3. Delk972

    Delk972 Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    Delk_mk
    Я уже пробовал... Инвентарь не сохраняется и высыпается куча ошибок в консоли... Ну поищу еще, может найдется нормальная версия, но вряд ли..
     
  4. inspectornaix

    inspectornaix Активный участник Пользователь

    Баллы:
    88
    Имя в Minecraft:
    inspector
    Ребят, столкнулся с непонятной ошибкой при запуске сервера. Добавляю моды и тут бац: https://pastebin.com/H0Lfjj4B
    Кто-нибудь сталкивался с таким? Или кто поможет разобраться? Заранее спасибо!
     
  5. HauserGrim

    HauserGrim Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    HauserGrim
    Если ядро 1.8.8, то тебе хватит и ViaVersion.
     
  6. UsernameAK

    UsernameAK Новичок Пользователь

    Баллы:
    16
    Как по команде удалить чанки без приватов?
     
  7. D1Xer

    D1Xer Активный участник Пользователь

    Баллы:
    76
    Skype:
    taraskarpin37
    Имя в Minecraft:
    TheTarasikPlay
    Можно фикс дюпа визера в регионе 1.7.10?
     
  8. Roots

    Roots Активный участник Пользователь

    Баллы:
    46
    Оо какой еще дюп ? с поршнями вытягивать блоки?
     
  9. D1Xer

    D1Xer Активный участник Пользователь

    Баллы:
    76
    Skype:
    taraskarpin37
    Имя в Minecraft:
    TheTarasikPlay
    Лол ты умеешь читать?
     
  10. Roots

    Roots Активный участник Пользователь

    Баллы:
    46
    Да только бывает с ошибка читаю =)
     
  11. tomxaos

    tomxaos Активный участник

    Баллы:
    61
    Доброе утро!
    Прошу объяснить мне, как только начавшему разработку сервера админу, что же консоль хочет ?



    [10:28:09] [RxComputationScheduler-1/WARN]: Exception in thread "RxComputationScheduler-1"
    [10:28:09] [RxComputationScheduler-1/WARN]: java.lang.IllegalStateException: Fatal Exception thrown on Scheduler.Worker thread.
    [10:28:09] [RxComputationScheduler-1/WARN]: at rx.internal.schedulers.ScheduledAction.run(ScheduledAction.java:59)
    [10:28:09] [RxComputationScheduler-1/WARN]: at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    [10:28:09] [RxComputationScheduler-1/WARN]: at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    [10:28:09] [RxComputationScheduler-1/WARN]: at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
    [10:28:09] [RxComputationScheduler-1/WARN]: at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
    [10:28:09] [RxComputationScheduler-1/WARN]: at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    [10:28:09] [RxComputationScheduler-1/WARN]: at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    [10:28:09] [RxComputationScheduler-1/WARN]: at java.lang.Thread.run(Thread.java:745)
    [10:28:09] [RxComputationScheduler-1/WARN]: Caused by: java.lang.NoClassDefFoundError: Could not initialize class io.puharesource.mc.titlemanager.reflections.Provider18
    [10:28:09] [RxComputationScheduler-1/WARN]: at io.puharesource.mc.titlemanager.reflections.NMSManager.getClassProvider(NMSManager.kt:40)
    [10:28:09] [RxComputationScheduler-1/WARN]: at io.puharesource.mc.titlemanager.APIProvider.sendActionbar(APIProvider.kt:562)
    [10:28:09] [RxComputationScheduler-1/WARN]: at io.puharesource.mc.titlemanager.APIProvider.sendActionbarWithPlaceholders(APIProvider.kt:586)
    [10:28:09] [RxComputationScheduler-1/WARN]: at io.puharesource.mc.titlemanager.TitleManagerPlugin.sendActionbarWithPlaceholders(TitleManagerPlugin.kt:683)
    [10:28:09] [RxComputationScheduler-1/WARN]: at io.puharesource.mc.titlemanager.extensions.PlayerExtensionsKt.sendActionbar(PlayerExtensions.kt:54)
    [10:28:09] [RxComputationScheduler-1/WARN]: at io.puharesource.mc.titlemanager.TitleManagerPlugin$registerListeners$3.invoke(TitleManagerPlugin.kt:402)
    [10:28:09] [RxComputationScheduler-1/WARN]: at io.puharesource.mc.titlemanager.TitleManagerPlugin$registerListeners$20.call(TitleManagerPlugin.kt:488)
    [10:28:09] [RxComputationScheduler-1/WARN]: at io.puharesource.mc.titlemanager.TitleManagerPlugin$registerListeners$20.call(TitleManagerPlugin.kt:44)
    [10:28:09] [RxComputationScheduler-1/WARN]: at rx.internal.util.ActionSubscriber.onNext(ActionSubscriber.java:39)
    [10:28:09] [RxComputationScheduler-1/WARN]: at rx.observers.SafeSubscriber.onNext(SafeSubscriber.java:134)
    [10:28:09] [RxComputationScheduler-1/WARN]: at rx.internal.operators.OnSubscribeFilter$FilterSubscriber.onNext(OnSubscribeFilter.java:76)
    [10:28:09] [RxComputationScheduler-1/WARN]: at rx.internal.operators.OperatorDelay$1$3.call(OperatorDelay.java:87)
    [10:28:09] [RxComputationScheduler-1/WARN]: at rx.internal.schedulers.EventLoopsScheduler$EventLoopWorker$2.call(EventLoopsScheduler.java:189)
    [10:28:09] [RxComputationScheduler-1/WARN]: at rx.internal.schedulers.ScheduledAction.run(ScheduledAction.java:55)
    • [10:28:09] [RxComputationScheduler-1/WARN]: ... 7 more
     
  12. Lightern

    Lightern Участник Пользователь

    Баллы:
    36
    Title manager ругается. Или версия не подходит, или меняй плагин.
     
  13. tomxaos

    tomxaos Активный участник

    Баллы:
    61
    Стоит у меня CraftBukkit on Bukkit 1.8-R0.1-SNAPSHOT
    Ядро: Spigot

    Может, есть варианты исправить что-то в конфиге?
    или в другом случае, какой плагин взамен этому поставить?
     
  14. Lightern

    Lightern Участник Пользователь

    Баллы:
    36
    Попробуй юзать 1.8.8+
     
  15. D1Xer

    D1Xer Активный участник Пользователь

    Баллы:
    76
    Skype:
    taraskarpin37
    Имя в Minecraft:
    TheTarasikPlay
    Я так и понял
     
  16. Lightern

    Lightern Участник Пользователь

    Баллы:
    36
    Ставишь ViaVersion и радуешься жизни)
     
  17. tomxaos

    tomxaos Активный участник

    Баллы:
    61
    До переустановки сервера, стояло ядро craftbukkit-1.8-R0.1. Так же с ним сразу установил плагин viaversion для входа со старших версий, соответственн у меня 1.12.2, мог заходить спокойно.
    Сейчас же стоит новый сервер, viaversion так же стоит на ядре spigot-1.8-R0.1-SNAPSHOT.

    теперь не могу зайти со старшей версии.. В чем может быть проблема? При необходимости, могу предоставить список плагинов
     
  18. HauserGrim

    HauserGrim Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    HauserGrim
    Дам совет, ядро 1.8.8 позволяет входить с 1.8 - 1.8.9, думаю так будет лучше.
    ( http://www.yivesmirror.com/grab/spigot/spigot-1.8.8-R0.1-SNAPSHOT.jar )
    Скачай последний билд ProtocolLib'a
    ( http://ci.dmulloy2.net/job/ProtocolLib/lastStableBuild/ )
    И убедись что юзаешь последнюю версию ViaVersion
     
  19. tomxaos

    tomxaos Активный участник

    Баллы:
    61
    ProtocolSupport
    Разобрался. Стояли два конфликтующих между собой плагина, вот и не давали зайти)

    Есть ещё один глупый вопрос... Даже стыдно как-то. Не собираюсь я создавать тему с подобными вопросами
    Есть два плагина ChestCommand (менюшка) и superTrails (эффекты для игроков, командой /trails вызывается отдельная менюшка с эффектами.)
    Вот что интернет: каким образом в меню запихнуть ссылку на эффекты?
     
  20. Roots

    Roots Активный участник Пользователь

    Баллы:
    46
    Ребята у меня есть BungeeCord и два сервера.
    Что я сделал Взял authme на 1 сервере привязял к mysql и на второму сервере так же
    /и в итоге два сервера и два authme к одному базе... Прикол в том что сессия остается Когда с 1 на второй перехожу
    PS. Это вообще нормально? или можно по другому как то ??
    Версия 1.12
    1.png
     
  21. _Truii_

    _Truii_ Активный участник

    Баллы:
    61
    Имя в Minecraft:
    _trui_
    скатился(
     

Поделиться этой страницей