Хостинг серверов Minecraft playvds.com
  1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.
  2. Вы находитесь в русском сообществе Bukkit. Мы - администраторы серверов Minecraft, разрабатываем собственные плагины и переводим на русский язык плагины наших собратьев из других стран.
    Скрыть объявление

Помогите Ошибка после перехода на другую версию

Тема в разделе "Разработка плагинов для новичков", создана пользователем Lucfierko, 2 ноя 2017.

  1. Автор темы
    Lucfierko

    Lucfierko Активный участник Пользователь

    Баллы:
    66
    Имя в Minecraft:
    Lucifer_
    Здравствуйте ребята, я не давно перешел с движка Spigot на Couldron, так как мне нужны еще для моего проекта моды forge, и вот, я писал плагины для сервера на версии 1.11.2 и мне пришлось перейти на 1.7.10 так как у Couldron выше нету, и теперь когда я запускаю сервер все работает кроме как загрузки моего плагина, подскажите в чем проблема, вот лог:
    Код:
    [17:22:02] [Server thread/WARN]: =============================================================
    [17:22:02] [Server thread/WARN]: MOD HAS DIRECT REFERENCE System.exit() THIS IS NOT ALLOWED REROUTING TO FML!
    [17:22:02] [Server thread/WARN]: Offendor: org/spigotmc/RestartCommand.restart()V
    [17:22:02] [Server thread/WARN]: Use FMLCommonHandler.exitJava instead
    [17:22:02] [Server thread/WARN]: =============================================================
    [17:22:02] [Server thread/INFO]: Generating keypair
    [17:22:02] [Server thread/INFO]: Starting Minecraft server on *:25565
    [17:22:02] [Server thread/WARN]: **** SERVER IS RUNNING IN OFFLINE/INSECURE MODE!
    [17:22:02] [Server thread/WARN]: The server will make no attempt to authenticate usernames. Beware.
    [17:22:02] [Server thread/WARN]: While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    [17:22:02] [Server thread/WARN]: To change this, set "online-mode" to "true" in the server.properties file.
    
    [17:22:04] [Server thread/ERROR]: Could not load 'plugins\dwar.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.IllegalStateException: JavaPlugin requires org.bukkit.plugin.java.PluginClassLoader
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:149) ~[JavaPluginLoader.class:KCauldron-1.7.10-2.1403.1.54]
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:334) ~[SimplePluginManager.class:KCauldron-1.7.10-2.1403.1.54]
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:256) [SimplePluginManager.class:KCauldron-1.7.10-2.1403.1.54]
        at org.bukkit.craftbukkit.v1_7_R4.CraftServer.loadPlugins(CraftServer.java:320) [CraftServer.class:KCauldron-1.7.10-2.1403.1.54]
        at net.minecraft.world.storage.SaveHandler.initBukkitData(SaveHandler.java:461) [ayq.class:?]
        at net.minecraft.world.storage.SaveHandler.func_75757_d(SaveHandler.java:137) [ayq.class:?]
        at net.minecraft.world.World.<init>(World.java:349) [ahb.class:?]
        at net.minecraft.world.WorldServer.<init>(WorldServer.java:153) [mt.class:?]
        at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:356) [MinecraftServer.class:?]
        at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:335) [lt.class:?]
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:620) [MinecraftServer.class:?]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_144]
    Caused by: java.lang.IllegalStateException: JavaPlugin requires org.bukkit.plugin.java.PluginClassLoader
        at org.bukkit.plugin.java.JavaPlugin.<init>(JavaPlugin.java:64) ~[JavaPlugin.class:KCauldron-1.7.10-2.1403.1.54]
        at ru.daymoon.dwar.Dwar.<init>(Dwar.java:15) ~[Dwar.class:?]
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_144]
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_144]
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_144]
        at java.lang.reflect.Constructor.newInstance(Unknown Source) ~[?:1.8.0_144]
        at java.lang.Class.newInstance(Unknown Source) ~[?:1.8.0_144]
        at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:201) ~[PluginClassLoader.class:KCauldron-1.7.10-2.1403.1.54]
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:145) ~[JavaPluginLoader.class:KCauldron-1.7.10-2.1403.1.54]
        ... 11 more
    [17:22:04] [Server thread/INFO]: Loading dimension 0 (world) (net.minecraft.server.dedicated.DedicatedServer@818fb)
    
    
    
    И вот из за этой ошибки плагин не запускается,а на версии 1.11.2 запускался, сразу к слову, движок в Eclipse для компиляции я поменял на 1.7.10 как и должно быть
     
  2. Mr Hosting
  3. Автор темы
    Lucfierko

    Lucfierko Активный участник Пользователь

    Баллы:
    66
    Имя в Minecraft:
    Lucifer_
  4. Автор темы
    Lucfierko

    Lucfierko Активный участник Пользователь

    Баллы:
    66
    Имя в Minecraft:
    Lucifer_
    Попробовал поменять на Jre 7 в компиляции, все равно выдает
    Код:
    [20:57:49] [Server thread/ERROR]: Could not load 'plugins\dwar.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.IllegalStateException: JavaPlugin requires org.bukkit.plugin.java.PluginClassLoader
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:149) ~[JavaPluginLoader.class:KCauldron-1.7.10-2.1403.1.54]
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:334) ~[SimplePluginManager.class:KCauldron-1.7.10-2.1403.1.54]
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:256) [SimplePluginManager.class:KCauldron-1.7.10-2.1403.1.54]
        at org.bukkit.craftbukkit.v1_7_R4.CraftServer.loadPlugins(CraftServer.java:320) [CraftServer.class:KCauldron-1.7.10-2.1403.1.54]
        at net.minecraft.world.storage.SaveHandler.initBukkitData(SaveHandler.java:461) [ayq.class:?]
        at net.minecraft.world.storage.SaveHandler.func_75757_d(SaveHandler.java:137) [ayq.class:?]
        at net.minecraft.world.World.<init>(World.java:349) [ahb.class:?]
        at net.minecraft.world.WorldServer.<init>(WorldServer.java:153) [mt.class:?]
        at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:356) [MinecraftServer.class:?]
        at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:335) [lt.class:?]
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:620) [MinecraftServer.class:?]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_144]
    Caused by: java.lang.IllegalStateException: JavaPlugin requires org.bukkit.plugin.java.PluginClassLoader
        at org.bukkit.plugin.java.JavaPlugin.<init>(JavaPlugin.java:64) ~[JavaPlugin.class:KCauldron-1.7.10-2.1403.1.54]
        at ru.daymoon.dwar.Dwar.<init>(Dwar.java:15) ~[Dwar.class:?]
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_144]
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_144]
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_144]
        at java.lang.reflect.Constructor.newInstance(Unknown Source) ~[?:1.8.0_144]
        at java.lang.Class.newInstance(Unknown Source) ~[?:1.8.0_144]
        at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:201) ~[PluginClassLoader.class:KCauldron-1.7.10-2.1403.1.54]
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:145) ~[JavaPluginLoader.class:KCauldron-1.7.10-2.1403.1.54]
        ... 11 more
    [20:57:50] [Server thread/INFO]: Loading dimension 0 (world) (net.minecraft.server.dedicated.DedicatedServer@3a3bd5)
    
    
     
  5. HunterGaming

    HunterGaming Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    HunterGaming13
    Плагин под Spigot, а ядро Cauldron, самому же можно понять, не?
     
  6. Автор темы
    Lucfierko

    Lucfierko Активный участник Пользователь

    Баллы:
    66
    Имя в Minecraft:
    Lucifer_
    А как можно совместить Forge и Spigot?
     
  7. HunterGaming

    HunterGaming Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    HunterGaming13
    Конкретно spigot скорее всего нельзя, ну а вообще я хз
     
  8. MrRateV2

    MrRateV2 Новичок Пользователь

    Баллы:
    21
    Имя в Minecraft:
    MrRate
    up
    несовместимость версий
     
  9. Jourdan

    Jourdan Новичок Пользователь

    Баллы:
    6
    Никак, для этого существует Sponge API. Вот форум русскоязычный:
    https://spongeapi.com
    Только на нем плагины от bukkit/spigot не работают.
     
  10. alexandrage

    alexandrage Старожил Пользователь

    Баллы:
    173
    Ошибка тут Dwar.java:15. А вообще собирай плагины на spigot 1.7.10 чтоб наверняка.
     
  11. HunterGaming

    HunterGaming Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    HunterGaming13
    org.bukkit.plugin.InvalidPluginException: java.lang.IllegalStateException: JavaPlugin requires org.bukkit.plugin.java.PluginClassLoader, не?
     

Поделиться этой страницей