Хостинг серверов Minecraft playvds.com
  1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.
  2. Вы находитесь в русском сообществе Bukkit. Мы - администраторы серверов Minecraft, разрабатываем собственные плагины и переводим на русский язык плагины наших собратьев из других стран.

Плагин ProtocolSupport [1.11] - Вы ещё сидите на старых версиях? Тогда мы идём к вам.

Тема в разделе "Неподтвержденные плагины", создана пользователем Shevchik, 27 май 2015.

  1. Bogdan2402

    Bogdan2402 Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    MrBogdan2402
    я это ядро прям обожаю, там еще можно даже отключить толкание игроков и многого другого
     
  2. Mr Hosting
  3. SimMiMo

    SimMiMo Активный участник Пользователь

    Баллы:
    76
    Последний протокол не дружит с ВиаВерсией, приходится юзать старый.
    Я лично юзаю Виа из-за ограничения пакетов в секунду.
    Просьба сделать что-то
    Код (Text):
    1. [01:01:13] [Server thread/INFO]: [ViaVersion] Loading ViaVersion v0.9.6
    2. [01:01:13] [Server thread/WARN]: java.lang.ClassNotFoundException: unknown.wrapped.WrappedDecoder
    3. [01:01:13] [Server thread/WARN]:     at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
    4. [01:01:13] [Server thread/WARN]:     at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101)
    5. [01:01:13] [Server thread/WARN]:     at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86)
    6. [01:01:13] [Server thread/WARN]:     at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    7. [01:01:13] [Server thread/WARN]:     at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    8. [01:01:13] [Server thread/WARN]:     at java.lang.Class.forName0(Native Method)
    9. [01:01:13] [Server thread/WARN]:     at java.lang.Class.forName(Class.java:264)
    10. [01:01:13] [Server thread/WARN]:     at us.myles.ViaVersion.classgenerator.ClassGenerator.generate(ClassGenerator.java:36)
    11. [01:01:13] [Server thread/WARN]:     at us.myles.ViaVersion.ViaVersionPlugin.onLoad(ViaVersionPlugin.java:106)
    12. [01:01:13] [Server thread/WARN]:     at org.bukkit.craftbukkit.v1_10_R1.CraftServer.loadPlugins(CraftServer.java:303)
    13. [01:01:13] [Server thread/WARN]:     at net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:203)
    14. [01:01:13] [Server thread/WARN]:     at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:535)
    15. [01:01:13] [Server thread/WARN]:     at java.lang.Thread.run(Thread.java:745)
    16. [01:01:13] [Server thread/INFO]: [ViaVersion] ViaVersion 0.9.6 is now loaded, injecting!
    17. [01:01:13] [Server thread/ERROR]: [ViaVersion] Have you got late-bind enabled with something else?
    18. [01:01:13] [Server thread/WARN]: java.lang.Exception: Unable to inject, due to protocolsupport.injector.network.NettyServerChannelHandler, try without the plugin ProtocolSupport?
    19. [01:01:13] [Server thread/WARN]:     at us.myles.ViaVersion.ViaVersionPlugin.inject(ViaVersionPlugin.java:325)
    20. [01:01:13] [Server thread/WARN]:     at us.myles.ViaVersion.ViaVersionPlugin.injectPacketHandler(ViaVersionPlugin.java:248)
    21. [01:01:13] [Server thread/WARN]:     at us.myles.ViaVersion.ViaVersionPlugin.onLoad(ViaVersionPlugin.java:111)
    22. [01:01:13] [Server thread/WARN]:     at org.bukkit.craftbukkit.v1_10_R1.CraftServer.loadPlugins(CraftServer.java:303)
    23. [01:01:13] [Server thread/WARN]:     at net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:203)
    24. [01:01:13] [Server thread/WARN]:     at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:535)
    25. [01:01:13] [Server thread/WARN]:     at java.lang.Thread.run(Thread.java:745)
    То же и с более новыми Виа
    @Shevchik
     
  4. BestMark

    BestMark Старожил Пользователь

    Баллы:
    103
    Skype:
    BestMarkBukkit
    Имя в Minecraft:
    BestMark
    Я думаю, не стоит юзать ViaVersion только из-за ограничения PPS. Та же функция есть в ядре Paper 1.10.2 или же в NoCheatPlus (только в последних dev-версиях).
     
  5. SimMiMo

    SimMiMo Активный участник Пользователь

    Баллы:
    76
    Я там все отключаю, нагрузки нет.
    Еще есть свой плагин, ловит пакеты смотрит что в них и считает некоторые.
    Чтобы предотвратить часть крашей
    --- Сообщения объединены: 13 ноя 2016, предыдущее сообщение: 13 ноя 2016 ---
    Пейпер не юзаю, он же не от мд_5.
    Про ноучит гляну, но мне приходится юзать 1.9 версию так как на 1.10 застревают в полублоках (мб можно пофиксить, но проще было старый поставить)
    --- Сообщения объединены: 13 ноя 2016 ---
    Еще вариант в свой это дописать..
     
  6. BestKVanT

    BestKVanT Активный участник Пользователь

    Баллы:
    66
    Имя в Minecraft:
    BestKVanT
    Застревают в полублоках из-за NCP (ставь последние дев билды) Бумага вполне себе нормальная, юзал и юзаю. Все отлично.
     
  7. Bogdan2402

    Bogdan2402 Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    MrBogdan2402
    Последний бил с поддержкой 1.11
    Когда захожу на версии 1.8.9, беру яйцо моба, выкидывает с сервера и больше я зайти не могу
    Версия ядра: PaperSpigot 1.11
     

    Вложения:

    Последнее редактирование: 20 ноя 2016
  8. BestKVanT

    BestKVanT Активный участник Пользователь

    Баллы:
    66
    Имя в Minecraft:
    BestKVanT
    Бумагу пока не ставь.
     
  9. Bogdan2402

    Bogdan2402 Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    MrBogdan2402
    Дело было даже не в ядре, шевчик уже поправил этот баг
     
  10. BestKVanT

    BestKVanT Активный участник Пользователь

    Баллы:
    66
    Имя в Minecraft:
    BestKVanT
    Я говорю в общем.
     
  11. Bogdan2402

    Bogdan2402 Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    MrBogdan2402
    неужели Paper такой дыряв?
     
  12. potatoesmcgee

    potatoesmcgee Активный участник Пользователь

    Баллы:
    61
    Skype:
    prezik1236
    Имя в Minecraft:
    Mr_Valestras
    Код (Text):
    1. [22:33:11 INFO]: [ProtocolSupport] Loading ProtocolSupport v4.25.dev
    2. [22:33:11 ERROR]: [ProtocolSupport] Unsupported server version, shutting down
    3. [22:33:11 INFO]: [ProtocolSupport] Allocator: PooledByteBufAllocator(directByDefault: true), direct: true
    4. [22:33:11 INFO]: [ProtocolSupport] Compression level: 3
    5. [22:33:11 WARN]: java.lang.NoClassDefFoundError: net/minecraft/server/v1_11_R1/PacketHandshakingInSetProtocol
    6. [22:33:11 WARN]:        at protocolsupport.protocol.packet.ServerBoundPacket.<clinit>(ServerBoundPacket.java:51)
    7. [22:33:11 WARN]:        at protocolsupport.ProtocolSupport.onLoad(ProtocolSupport.java:39)
    8. [22:33:11 WARN]:        at org.bukkit.craftbukkit.v1_10_R1.CraftServer.loadPlugins(CraftServer.java:304)
    9. [22:33:11 WARN]:        at net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:207)
    10. [22:33:11 WARN]:        at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:590)
    11. [22:33:11 WARN]:        at java.lang.Thread.run(Unknown Source)
    12. [22:33:11 WARN]: Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_11_R1.PacketHandshakingInSetProtocol
    13. [22:33:11 WARN]:        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:92)
    14. [22:33:11 WARN]:        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:87)
    15. [22:33:11 WARN]:        at java.lang.ClassLoader.loadClass(Unknown Source)
    16. [22:33:11 WARN]:        at java.lang.ClassLoader.loadClass(Unknown Source)
    17. [22:33:11 WARN]:        ... 6 more
     
  13. CnoWes

    CnoWes Активный участник Пользователь

    Баллы:
    78
    Имя в Minecraft:
    CnoWes
    эта бумага подобие спигота, нет смысла вообще в нём
     
  14. Bogdan2402

    Bogdan2402 Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    MrBogdan2402
    там много классных функций, вот например можно убрать толкание игроков, еще там есть ограничения в пакетах, как и в ViaVersion
     
  15. BestKVanT

    BestKVanT Активный участник Пользователь

    Баллы:
    66
    Имя в Minecraft:
    BestKVanT
    это есть и в NCP в последних билдах.
     
  16. Bogdan2402

    Bogdan2402 Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    MrBogdan2402
    Версия ядра: 1.11
    Если зайти со старой версии на сервер(проверял 1.8-1.10.2), то не отображаются названия лежащих на земле предметов. На 1.11 все нормально.
    Этот баг был и на старых версиях ProtocolSupport.

    С новым билдом яйца призыва стали работать, но они все еще белые
     

    Вложения:

  17. PA3OP

    PA3OP Новичок Пользователь

    Баллы:
    21
    Имя в Minecraft:
    PA3OP
    Ребят а можно сделать чтобы он работал на версии 1.8-1.11? Мне не надо чтобы он работал на 1.5.2 и т.д.
     
  18. SimMiMo

    SimMiMo Активный участник Пользователь

    Баллы:
    76
    у меня лично 1.7-1.11.2
    Ответ - да )
     
  19. PA3OP

    PA3OP Новичок Пользователь

    Баллы:
    21
    Имя в Minecraft:
    PA3OP
    Ребят есть протокол на ядро spigot 1.10? 1.11.2 не использую, т.к. некоторые плагины у меня не совместимы с ядром 1.11.2. Обновляь робовал - бесполезно...
     
  20. BestMark

    BestMark Старожил Пользователь

    Баллы:
    103
    Skype:
    BestMarkBukkit
    Имя в Minecraft:
    BestMark
    Ищи на Jenkins по изменениям. Мне кажется, билд 620 будет совместим, если ты юзаешь 1.10.2.
     
  21. PA3OP

    PA3OP Новичок Пользователь

    Баллы:
    21
    Имя в Minecraft:
    PA3OP
    Я уже все, нашел. Я юзаю 1.10
     

Поделиться этой страницей