Хостинг серверов Minecraft playvds.com
  1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.
  2. Вы находитесь в русском сообществе Bukkit. Мы - администраторы серверов Minecraft, разрабатываем собственные плагины и переводим на русский язык плагины наших собратьев из других стран.

Плагин [SEC/FIX] WGExtender [1.10+] [WG6.1.3+, WE6.1.4+]

Тема в разделе "Релизы плагинов", создана пользователем Shevchik, 21 мар 2014.

  1. Fiks75

    Fiks75 Участник

    Баллы:
    31
    В Spigot 1.11 (WorldGuard 6.1.5, WorldEdit 6.1.6) не правильно работает расширение региона. К примеру выделено 4000 блоков, вводится команда /rg claim test и тут же выскакивает сообщение о превышении лимита привата в 80000 блоков. То есть расширяет регион в 20 раз больше. Удалил WGExtender и стало все нормально работать.
     
  2. Mr Hosting
  3. Автор темы
    Shevchik

    Shevchik Старожил Пользователь

    Баллы:
    173
    Имя в Minecraft:
    _Shevchik_
    На все 256 блоков в высоту расширяет, а лимит учитывает расширение по вертикали. Всё тут правильно работает.
     
  4. Lonadelsi

    Lonadelsi Участник Пользователь

    Баллы:
    31
    Имя в Minecraft:
    Jared16
    Автор, можете сделать в теме так?

    Неудобно на Вашем Jenkins искать билды нужных версий. Тема Ваша совсем не оформлена, Вы издеваетесь над пользователями.

    Неужели Ваш плагин подойдёт к 1.7.10? Конечно, нет, потому что WG и WE собраны под новые версии. Где я Ваш WGEx должен искать на 1.7.10, да так, чтобы был последний билд для этой версии?
     
  5. Автор темы
    Shevchik

    Shevchik Старожил Пользователь

    Баллы:
    173
    Имя в Minecraft:
    _Shevchik_
    Ответ: нигде, потому что я не поддерживаю не последнюю версию, поэтому где и как вы собрались искать что-то для 1.7.10 меня не волнует.
     
  6. Lonadelsi

    Lonadelsi Участник Пользователь

    Баллы:
    31
    Имя в Minecraft:
    Jared16
    Автор, это просто какой-то мега пофигизм. Зачем так делать? Не всем нравятся последние версии MC, а я хочу последнюю сборку WGExtender, работающую на 1.7.10.

    К тому же, большинство модификаций (Forge) сделано на 1.7.10, и не обновлены до новых версий.
     
  7. Автор темы
    Shevchik

    Shevchik Старожил Пользователь

    Баллы:
    173
    Имя в Minecraft:
    _Shevchik_
    Если сильно нужно - сам и ищи. У меня нет ни времени ни желания. К тому же рано или поздно я почищу старые билды потому что жёсткий диск не резиновый.
     
  8. Lonadelsi

    Lonadelsi Участник Пользователь

    Баллы:
    31
    Имя в Minecraft:
    Jared16
    Хорошо. Если я буду собирать исходники, которые на гитхаб, под Spigot 1.7.10, заработает ли jar файл, или там придётся что-то менять?
     
  9. Автор темы
    Shevchik

    Shevchik Старожил Пользователь

    Баллы:
    173
    Имя в Minecraft:
    _Shevchik_
    Откуда я знаю?
     
  10. Lonadelsi

    Lonadelsi Участник Пользователь

    Баллы:
    31
    Имя в Minecraft:
    Jared16
    Ты делаешь плагин, или у тебя сосед приходит, кодит, всё собирает, синхронизует на Jenkins, а ты просто тему обновляешь?
     
  11. InterWall

    InterWall Старожил Пользователь

    Баллы:
    173
    Имя в Minecraft:
    InterWall
    Раз таком умный — вперед и с песней. Никто не мешает взять и собрать.
     
  12. Lonadelsi

    Lonadelsi Участник Пользователь

    Баллы:
    31
    Имя в Minecraft:
    Jared16
    Я заранее спрашиваю, если я соберу сейчашние исходники под 1.7.10, будет ли это работать, или же там все переделывать придётся.
     
  13. Автор темы
    Shevchik

    Shevchik Старожил Пользователь

    Баллы:
    173
    Имя в Minecraft:
    _Shevchik_
    Чтобы это узнать надо хоть раз попробовать собрать последнюю версию под 1.7.10, и использовать wg и we 1.7.10. По очевидной причине я ни разу этого не делал, поэтому не знаю соберётся он или нет.
     
  14. InterWall

    InterWall Старожил Пользователь

    Баллы:
    173
    Имя в Minecraft:
    InterWall
    Я потратил 15 секунд на поиск версии для ВГ < 6 версии.
    Снимок экрана 2016-12-03 в 14.34.08.png
    --- Сообщения объединены: 3 дек 2016, предыдущее сообщение: 3 дек 2016 ---
    Дальше больше, пара минут на поиск билда, который по коммитам должен работать на 1.7.10
    http://build.true-games.org/job/WorldGuardExtender/169/
     
  15. Lonadelsi

    Lonadelsi Участник Пользователь

    Баллы:
    31
    Имя в Minecraft:
    Jared16
    Спасибо большое, Вы попадёте в рай без очереди. Хорошо, что Вы решили поискать, я бы сам не взялся)
    А тут можно как-нибудь кнопочкой "спасибо" сказать, или на этом форуме нет такой функции?
     
  16. InterWall

    InterWall Старожил Пользователь

    Баллы:
    173
    Имя в Minecraft:
    InterWall
    Уже нет, мне достаточно простого "спасибо". :)
     
  17. TimeRiver

    TimeRiver Активный участник

    Баллы:
    61
    Имя в Minecraft:
    TimeRiver
    Помогите пожалуйста
    WGE насилует консоль этим

    [13:41:52 ERROR]: [WGExtender] Unable to check isFlagAllows
    [13:41:52 ERROR]: [WGExtender] com.sk89q.worldguard.protection.RegionResultSet.allows(com.sk89q.worldguard.bukkit.BukkitPlayer)


    Конфиг

    claim:
    vertexpand:
    enabled: true
    blocklimits:
    enabled: false
    limits: {}
    regionprotect:
    flow:
    lava:
    enabled: false
    water:
    enabled: false
    ignitebyplayer:
    enabled: false
    fire:
    spread:
    toregion:
    enabled: false
    inregion:
    enabled: false
    burn:
    enabled: false
    explosion:
    block:
    enabled: false
    entity:
    enabled: false
    pistonmove:
    enabled: false
    customflags:
    damage-animals:
    enabled: true
    block-interact:
    enabled: true
    entity-interact:
    enabled: true
    autoflags:
    enabled: true
    flags:
    pvp: deny
    restrictcommands:
    enabled: false
    commands: []
     
  18. KuroyuriLP

    KuroyuriLP Активный участник Пользователь

    Баллы:
    66
    Не подскажешь что за ошибка?
    > [13:41:50 ERROR]: Could not pass event EntityDamageByEntityEvent to WGExtender v1.0
    org.bukkit.event.EventException
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:310) ~[craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:487) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at org.bukkit.craftbukkit.v1_8_R3.event.CraftEventFactory.callEvent(CraftEventFactory.java:87) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at org.bukkit.craftbukkit.v1_8_R3.event.CraftEventFactory.callEntityDamageEvent(CraftEventFactory.java:553) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at org.bukkit.craftbukkit.v1_8_R3.event.CraftEventFactory.handleEntityDamageEvent(CraftEventFactory.java:466) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at org.bukkit.craftbukkit.v1_8_R3.event.CraftEventFactory.handleLivingEntityDamageEvent(CraftEventFactory.java:585) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at net.minecraft.server.v1_8_R3.EntityLiving.d(EntityLiving.java:1102) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at net.minecraft.server.v1_8_R3.EntityLiving.damageEntity(EntityLiving.java:743) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at net.minecraft.server.v1_8_R3.EntityHuman.attack(EntityHuman.java:1001) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at net.minecraft.server.v1_8_R3.EntityPlayer.attack(EntityPlayer.java:1063) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at net.minecraft.server.v1_8_R3.PlayerConnection.a(PlayerConnection.java:1355) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at net.minecraft.server.v1_8_R3.PacketPlayInUseEntity.a(SourceFile:52) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at net.minecraft.server.v1_8_R3.PacketPlayInUseEntity.a(SourceFile:11) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at net.minecraft.server.v1_8_R3.PlayerConnectionUtils$1.run(SourceFile:13) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_92]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_92]
    at net.minecraft.server.v1_8_R3.SystemUtils.a(SourceFile:44) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:715) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557) [craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_92]
    Caused by: java.lang.NoSuchMethodError: org.bukkit.inventory.PlayerInventory.getItemInMainHand()Lorg/bukkit/inventory/ItemStack;
    at wgextender.features.extendedwand.WEWandListener.onEntityAttack(WEWandListener.java:39) ~[?:?]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_92]
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_92]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_92]
    at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_92]
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[craftbukkit-Spigot-1.8.8-R0.1.jar:git-Spigot-06ad352-4a7472d]
    ... 23 more
     
  19. Kixot14

    Kixot14 Активный участник Пользователь

    Баллы:
    88
    Skype:
    Kixot14
    Имя в Minecraft:
    F1xer
    Автор какой то хамовитый до ужаса
    --- Сообщения объединены: 27 дек 2016, предыдущее сообщение: 27 дек 2016 ---
    Идея плагина хорошая, конечно же, только жаль недоделанная! Не хватило усилий автору. Очень жаль
     
  20. slavik123123123

    slavik123123123 Старожил Пользователь

    Баллы:
    143
    Имя в Minecraft:
    Leymooooooooooo
    жалко что плагину скоро 4 года, а он не доделан(
    Как по мне плагин доделан до конца, и нормальных альтернатив ему нету.
     
  21. Kixot14

    Kixot14 Активный участник Пользователь

    Баллы:
    88
    Skype:
    Kixot14
    Имя в Minecraft:
    F1xer
    ну ну. Подержи у себя на сервере этот плагин недельку-другую
     

Поделиться этой страницей