Хостинг серверов Minecraft playvds.com
  1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.
  2. Вы находитесь в русском сообществе Bukkit. Мы - администраторы серверов Minecraft, разрабатываем собственные плагины и переводим на русский язык плагины наших собратьев из других стран.
    Скрыть объявление

PSA: Minecraft 1.10.2 and 1.11.2

Тема в разделе "Официальные новости Sponge", создана пользователем RuBukBot, 12 дек 2017.

  1. Автор темы
    RuBukBot

    RuBukBot Робот RuBukkit Модератор

    Баллы:
    103
    PSA: Minecraft 1.10.2 and 1.11.2
    @gabizou wrote:


    As many of you may know by now, a lot of our development has increased to have support for 1.10.2 and 1.11.2 and 1.12.2, with some API development towards Minecraft 1.13. As of this writing, the Sponge team has been planning on dropping support for 1.11.2 for a while, at the very least when API 7 for Minecraft 1.12.x is officially released. I am pleased to say that API 7 now has a release date of December 31st, 2017. What this will mean is that API 5 and 6 will no longer be supported, meaning Minecraft 1.10.2 and 1.11.2 will no longer be supported for API additions or bug fixes.

    There is a lot of reasoning behind this, the largest reason is the direction of development and the time available to the development team towards resolving bugs to systems that have now been rewritten, refactored, improved, and replaced, since API 5 was introduced. Some of you may think “Well, why don’t you support 1.10.2 for a little bit longer? At least until 1.13 drops, or when larger modpacks are released for 1.12.2 or 1.13?” and my answer to that is simple: “It’s time to move on.” Bugs that are affected on older versions of Sponge are related to older systems (including the system formerly known as CauseTracker, now known as PhaseTracker) having certain limitations and stability requirements according to Minecraft’s development status. Diverting time and energy to support issues for older versions that are no longer in development, and requiring the team to attempt to replicate the issue, if necessary, on newer versions due to a small chance of a shared implementation in comparison, is considered a waste when it can be spent on improving the project in current developments.

    While this may be a shock for some of you, it is a requirement and has always been said in the past that the Sponge project must always look forward, and not to the past. While it may have been probable to support 1.10.2 for a little while longer, I as a leader of the project, cannot ask more of the team to spend time and energy to support a version that has no future.

    With that said, January 1st, 2018 will be the day that all issues related to 1.10.2 and 1.11.2 will be closed on the basis of being a no longer supported version, unless the issue is still reproducible on the latest version of either bleeding or stable release of SpongeForge/SpongeVanilla on Minecraft 1.12.2. If a sufficiently, decent, and tested PR for a bug fix is made by a non-core developer of the Sponge team, it would still be considered, even for 1.10.2; however, it is NOT to be expected that any bug fixes made for 1.12.2 will be back ported to 1.11.2 or 1.10.2.

    Posts: 1

    Participants: 1

    Read full topic
     
  2. Mr Hosting

Поделиться этой страницей