Хостинг серверов Minecraft playvds.com
  1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.
  2. Вы находитесь в русском сообществе Bukkit. Мы - администраторы серверов Minecraft, разрабатываем собственные плагины и переводим на русский язык плагины наших собратьев из других стран.
    Скрыть объявление

Помогите ViaVersion, поддержка нескольких версий

Тема в разделе "Помощь", создана пользователем Swersik, 4 июн 2018.

Статус темы:
Закрыта.
  1. Автор темы
    Swersik

    Swersik Активный участник Пользователь

    Баллы:
    61
    Имя в Minecraft:
    Mr_Swersik
    Сервер стоит на крафтбакките 1.11.2. Реализовал, чтобы можно было войти от 1.9 до 1.12.2. Войти можно, проблем нет, но вот зайдя на свой сервер с 1.12.2, ставить новые блоки нельзя, в чём проблема? Юзал пермишены, флаги регионов, то есть проблема конкретно в плагине ViaVersion, но конфига на разрешение строительства не нашёл.
     
  2. Mr Hosting
  3. kefavova

    kefavova Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    kefa
    Всё правильно, ViaVersion блокирует все новые блоки и оставляет только те которые есть в версии 1.9...
     
  4. HauserGrim

    HauserGrim Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    HauserGrim
    У тебя же на 1.9 не будут отображаться блоки из 1.11, потому, что на клиенте их нет.
    Так же и на 1.11, для сервера не существует блоков из 1.12.
     
  5. Автор темы
    Swersik

    Swersik Активный участник Пользователь

    Баллы:
    61
    Имя в Minecraft:
    Mr_Swersik
    Верно, в клиенте 1.9 нет новых блоков с 1.12.2. Но всё же, можно ли как-то реализовать мой замысел? Подогнать сервер чтобы он принимал эти новые блоки (повторюсь, сервер на 1.11.2). Визуально всё выглядело бы так: игрок с версии 1.12.2 ставит новые блоки, а игрок с 1.9 видит вместо них другие текстуры.
     
  6. Shevchik

    Shevchik Старожил Пользователь

    Баллы:
    173
    Имя в Minecraft:
    _Shevchik_
    Сервер остаётся геймплейно на той же версии. Грубо говоря у тебя есть всё что есть на 1.11.2.
     
  7. Xxx_MrArtem_xxX

    Xxx_MrArtem_xxX Активный участник Пользователь

    Баллы:
    61
    Имя в Minecraft:
    Xxx_MrArtem_xxX
    Я юзаю ProtocolSupport
     
  8. Автор темы
    Swersik

    Swersik Активный участник Пользователь

    Баллы:
    61
    Имя в Minecraft:
    Mr_Swersik
    Какая версия ядра у тебя? С каких версий к тебе могут заходить игроки?
     
  9. CriticaMobslps

    CriticaMobslps Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    CriticaMobs
    ProtocolSupport делает заход с версий ниже версии ядра
     
  10. Автор темы
    Swersik

    Swersik Активный участник Пользователь

    Баллы:
    61
    Имя в Minecraft:
    Mr_Swersik
    То есть с этим плагином игроки не смогут заходить с версий выше ядра? ViaVersion даёт возможность заходить с версий выше, и к этому плагину идёт ViaBackwards, который добавляет возможность входа с версий ниже.
     
  11. CriticaMobslps

    CriticaMobslps Активный участник Пользователь

    Баллы:
    76
    Имя в Minecraft:
    CriticaMobs
    Ну я просто могу тебе сказать что я юзал раньше ViaVersion + ProtocolSupport
     
  12. Автор темы
    Swersik

    Swersik Активный участник Пользователь

    Баллы:
    61
    Имя в Minecraft:
    Mr_Swersik
    По сути, ProtocolSupport и ViaBackwards исполняют одну и ту же роль - вход игроков с версий ниже ядра.

    Вообщем самое оно - писать свои плагины и затачивать их под последнее ядро, таким образом всё будет отлично. А иначе входить с новых версий смогут, а строить нет.
    Закрываю тему.
     
Статус темы:
Закрыта.

Поделиться этой страницей